注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

男儿当自强的博客

每天进步一点

 
 
 

日志

 
 
 
 

WINCE开机显示logo之前先显示白屏的问题  

2010-12-19 16:57:56|  分类: wince的bootloade |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

WINCE开机显示logo之前先显示白屏的问题

********************************LoongEmbedded********************************

作者:LoongEmbedded(kandi)

时间:2010.12.19

类别:WINCE驱动开发

********************************LoongEmbedded********************************

 

系统:WINCE6.0+S3C2443

Bug:开机的时候,先显示白屏(很快就过去了)然后再显示eboot的logo信息。

解决思路:

1.       在显示eboot的logo之前关闭背光供电。

本来是想在stepldr中通过关闭对背光IC AT1312B的功能来解决掉这个bug的,但不管我放在stepldr中哪个位置都不能解决这个问题,也就是GPC6输出低电平,见下图

WINCE开机显示logo之前先显示白屏的问题 - 男儿当自强 - 男儿当自强的博客

图1

即使在OEMPlatformInit函数调用InitDisplay函数中关闭背光IC的供电,在InitDisplay函数和gDispPhoto函数之间开启背光IC的供电一样不能解决。

WINCE开机显示logo之前先显示白屏的问题 - 男儿当自强 - 男儿当自强的博客

图2

后来只能推迟背光IC的供电时间,还是在OEMPlatformInit函数的下面代码处开启对背光IC的供电才能解决这个问题,见下图

WINCE开机显示logo之前先显示白屏的问题 - 男儿当自强 - 男儿当自强的博客

图3

2.       通过PWM把背光的亮度调到黑屏。

这种办法是通过调低背光IC的亮度来来实现的,需要添加的地方有两种

⑴在OEMPlatformInit函数开始的地方初始化好PWM并且将背光调至黑屏的亮度,这要根据不同的CPU的PWM相关参数和背光IC来设置,可以参考我的另一篇博文

http://blog.csdn.net/LoongEmbedded/archive/2010/12/16/6079080.aspx

WINCE开机显示logo之前先显示白屏的问题 - 男儿当自强 - 男儿当自强的博客

图4

⑵在OEMPlatformInit函数的下面的地方重新调亮背光来显示eboot的logo,也就错开了显示白屏的时间

WINCE开机显示logo之前先显示白屏的问题 - 男儿当自强 - 男儿当自强的博客

图5

  评论这张
 
阅读(1133)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017